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Publishing SWF Files for After Effects
As you can see, there are a lot of technical issues surrounding video that you 

need to be aware of before creating your Flash movie. Let’s apply what you 

have just learned by exploring how to migrate Flash movies to After Effects. 

There are several ways to do this. Let’s start with a SWF file published in Flash. 

Flash can export content to a SWF file, QuickTime movie, and an image 

sequence. All of these formats can be imported into After Effects. After Effects 

is one of the few applications that supports a wide variety of file types. SWF 

files are imported into After Effects as flattened, continuously rasterized layers. 

This means they can be scaled without losing detail or quality. 

Locate the Chapter_02 folder on the DVD. Copy this folder to your hard drive. 
The folder contains all the files needed to complete the chapter exercises.

The first exercise provides a step-by-step tutorial on importing a SWF file into 

After Effects. To see what you will build, locate and play the BikeRide.mov

in the Completed folder inside the 01_SWF folder (Figure 2.10). When you 

finish this exercise you will be able to set up a Flash animation that will import 

correctly into After Effects, and create a seamless scrolling background.

Figure 2.10: The finished SWF file in After Effects.

Launch1. Adobe Flash. Locate and open Cycling.fla in the 01_SWF folder inside 

Chapter_02. The file contains a looping animation of the cyclist. 

The Stage dimensions are set for NTSC D1 video at 720 x 540 (square) pixels.3

The frame rate is set to 30 fps.3

The background color is not important. After Effects imports SWF files 3

with their alpha channel preserved.
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The root Timeline consists of one animated graphic symbol that occupies the 2.

first 15 frames. Scrub through the Timeline to see the animation. Double-click 

on the graphic symbol to open its Timeline (Figure 2.11).

Figure 2.11: The cyclist animation is made up of several layers.

The looping animation consists of several layers of artwork. Motion tweens 

are applied to nested graphic symbols that only change in position over time. 

These include the head, sneakers, and bicycle wheels. The legs, arms, and shirt 

are vector shapes that morph over time. Shape tweens and shape hints are 

used to create the desired movement.

Return to the root Timeline by clicking on Scene 1. Why use a graphic symbol 3.

instead of a movie clip? Movie clips are the most popular type of symbol used 

in interactive projects. Unfortunately for this exercise, the movie clip is useless. 

If you change the symbol type from a graphic to a movie clip and publish the 

SWF file it will play back correctly in the Flash Player. However, once imported 

into After Effects, the symbol will just sit there on its first frame and do nothing 

else. Avoid using movie clips when saving a Web-based animation to video. 

Convert all existing movie clips to graphic symbols (Figure 2.12).

Figure 2.12: Use graphic symbols when converting Flash animation to video.



Publishing SWF Files for After Effects 47

Test the movie to see the animation. A SWF file has already been published and 4.

saved to the 01_Footage folder in the 01_SWF folder inside Chapter_02. There 

is one other footage file you will use to complete this exercise. Double-click on 

Forest.psd inside the Footage folder to launch the file in Adobe Photoshop. This 

artwork will be used for the scrolling background. 

The image height is 540 pixels which matches the height of the Flash Stage. 3

It is also the correct square pixel height to use for NTSC D1 video.

To create a seamless scroll the image was duplicated and flipped horizontally 3

so that the edges align (Figure 2.13).

Figure 2.13: Duplicate and flip the image horizontally to create a seamless image.

Launch5. Adobe After Effects. It opens an empty project by default.

Import the footage files. Double-click inside the Project panel. This opens the 6.

Import File dialog box. Locate the 01_Footage folder inside the 01_SWF folder 

you copied to your hard drive. Select the folder. Click on Import Folder.

Figure 2.14: Import the 01_Footage folder into the Project panel.

Deselect the 01_Footage folder in the Project panel by clicking on the gray area 7.

under the footage. Click on the New Folder icon at the bottom of the Project 

panel. Rename the new folder to Comps.

Select8. Composition > New Composition. Enter BikeRide as the Composition 

Name. Select NTSC D1 from the Preset popup menu. Set the duration to 

0:00:05:00. Click OK to create the new composition.
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Selecting a video preset in After Effects automatically configures the correct 9.

frame rate and pixel aspect ratio for the composition. The new composition has 

a frame rate of 29.97 fps. The SWF footage has a different frame rate of 30 fps. 

To conform its frame rate to match the composition’s:

Twirl open the 3 01_Footage folder to reveal its contents in the Project panel.
Single-click on the Cycling.swf footage to select it.

Select3 File > Interpret Footage > Main.

In the Frame Rate section, select3  Conform to frame rate and enter 29.97.

In the Other Options section, enter 3 10 for the number of loops.

Click3 OK. Conforming the frame rate does not affect the original file, only 

the linked footage in the Project panel. After Effects changes the internal 

duration of frames but not the frame content.

Figure 2.15: The Interpret Footage dialog box allows you to conform frame rates. 

Click and drag the 10. 01_Footage folder from the Project panel to the left side 

of the Timeline. Release the mouse. Two layers appear in the Timeline and 

the Composition panel displays the artwork.

Figure 2.16: Add the layers to the Timeline. 

The artwork is larger than the Comp Window. Remember that the footage was 11.

created using square pixels. To compensate for non-square pixels in video, you 

need to rescale the layers to fit the dimensions of the Comp Window. In the 

Timeline panel, deselect both layers by clicking on the gray area underneath. 
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Select only the 12. Cycling.swf layer. Then select Layer > Transform > Fit to Comp.

The width and height of the layer snap to the dimensions of the Comp Window. 

The bicycle wheels will look slightly flattened but will appear as circles on video.

Figure 2.17: Round objects will appear stretched on the computer screen which is 
displaying only square pixels. On video, these shapes will appear normal. 

To see how the image will look on video click on the 13. Toggle Pixel Aspect Ratio 

Correction button in the bottom right corner of the Composition panel (Figure 

2.18). Click on the toggle button again to view in square pixels.

This function does not affect the final rendering, however, it does distort the 

layers displayed in the Comp Window. This distortion can produce unwanted 

jagged images. Turn this toggle button on only to preview the image. Turn it 

off while you are building the project to view the full anti-aliased images. 

Figure 2.18: The Toggle Pixel Aspect Ratio Correction button provides a preview 
of how the image will look in a non-square pixel aspect ratio. 

Click on the 14. RAM Preview button. The cyclist is going nowhere. The final step 

is to create the scrolling background. Before you do that, save your project.

Let’s focus on the background image. Only the height of the 15. Forest.psd layer 

needs to conform to the height of the Comp Window. Select the Forest.psd

layer. Then select Layer > Transform > Fit to Comp Height.

With the 16. Forest.psd layer still highlighted in the Timeline, select Effect > 

Distort > Offset. The Offset filter in After Effects is similar to Offset in 

Photoshop. It pans the image within a layer. Visual information pushed off 

one side of the image appears on the opposite side.

Press the 17. Home key on the keyboard. This moves the Current Time Indicator 

to the beginning of the composition (00:00). You first need to record the 

layer’s center point position. This position will animate over time. 
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Go to the Effect Controls panel. Click on the 18. stopwatch icon      next to Shift

Center To. This generates a keyframe at the beginning of the composition.

Press the19.  End key to move the CTI to the end of the Timeline (05:00).

Go to the Effect Controls panel. Change the first value to 20. 6000 (Figure 2.19). 

The image’s center point animates over time. Since the Photoshop file was 

designed to be seamless, the end result is a continuous scrolling background. 

Figure 2.19: Shift the horizontal center of the image to create the scrolling movement. 

Before you render the composition, let’s make sure that the colors will display 21.

properly in NTSC video. Select Layer > New > Adjustment Layer.

Select22. Effect > Color Correction > Broadcast Colors. The effect is applied to all 

layers through the adjustment layer. It alters the pixel color values to keep the 

composition’s color space within the range allowed for broadcast video.

Figure 2.20: Apply the Broadcast Colors effect to an adjustment layer to keep the 
composition’s color space within the color range allowed for NTSC and PAL video.

Click on the 23. RAM Preview button. Save your project. 

Select24. Composition > Make Movie. This opens the Render Queue. 

Click on 25. Lossless next to Output Module. Set the Format to QuickTime movie. 

Click on Format Options and set the compression setting to MPEG-4 Video.

Click on Output To and select the Chapter_02 folder on your hard drive as 

the final destination for the rendered movie.

Click the 26. Render button. This completes the exercise. An important concept 

to remember is to use graphic symbols instead of movie clips when publishing 

Flash SWF files for After Effects. Also, the Offset effect is a quick way to create 

scrolling background images.
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Using the QuickTime Exporter
Exporting SWF files for After Effects is quite simple as long as you remember to 

keep your artwork as vector shapes or stored in graphic symbols. What happens 

if the animation is driven by ActionScript? Welcome to the QuickTime Exporter. 

The QuickTime Exporter in Flash allows you to save your movies as a QuickTime, 

Windows AVI, or an image sequence. There are two methods in which you can 

export your Flash file. The first method renders on a frame-by-frame basis all 

content placed directly on the Flash Timeline. The second option allows you to 

export dynamic content over a period of time. This includes ActionScript-driven 

animation that uses movie clips. Let’s explore each method in detail.

This exercise provides a step-by-step tutorial on using the Flash QuickTime 

Exporter to save content on the Timeline to a fixed-frame video format. Unlike 

the SWF file in the first exercise, movie clips are supported using this first 

method. The artwork can be a movie clip, a graphic symbol or vector shape.

Figure 2.21: It is better to break scenes from a large Flash animation into separate 
FLA files. Use After Effects to edit the exported clips back together into one movie.

Open the 1. 02_QuickTimeExporter folder inside the Chapter_02 folder. When 

creating animation for video, save each scene as a separate Flash FLA file 

(Figure 2.21). Even though Flash can store multiple scenes in one large movie, 

having smaller individual files provides easier editing capabilities in After Effects. 

It also reduces the risk of file corruption that could occur using longer timelines. 

Double-click on 2. scene_01.fla to open the file in Flash. The animation is made 

up of several layers. The artwork is either nested within a graphic symbol or a 

vector shape drawn on the Stage. 

The top layer labeled SAFE AREA contains the Title Safe and Action Safe guides 

for NTSC D1 video. All titles and text are framed within the Title Safe area 

(Figure 2.22). Notice that it is a guide layer. It is visible in the Flash FLA file but 

will not be included in the exported movie.

Title Safe and Action Safe templates are provided in the Chapter_02 folder for 
you to use in your projects. Simply copy the frame and paste it into your file. 



52 Chapter 2: From Flash to After Effects

Figure 2.22: The title is contained within the Title Safe area.

Unlike the previous exercise, the artwork in this Flash file uses only NTSC video 3.

safe colors. The default color swatches were replaced with the NTSC color 

palette provided by www.animonger.com (Figure 2.23).

Select4. File > Export > Export Movie. This opens the QuickTime Movie dialog 

box. Select the 02_QuickTimeExporter folder inside the Chapter_02 folder on 

your hard drive as the final destination for the rendered movie. Make sure the 

file format is set to QuickTime. Click Save.

Figure 2.24: QuickTime Export Settings provides several options to choose from.

The QuickTime Export Settings dialog box appears. Make sure the width and 5.

height are set to 720 and 540 respectively. The Stop Exporting area provides 

Figure 2.23: Only NTSC 
video safe colors were used 
to create the artwork.
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the two exporting methods mentioned at the beginning of this exercise. Since 

this Flash movie is a frame-by-frame animation, you want to stop exporting 

when the last frame is reached. Click on QuickTime Settings.

The Movie Settings dialog box allows you to adjust the video and audio 6.

settings. There is no audio in this file. Turn off the audio export by unchecking 

the checkbox next to Sound (Figure 2.25).

Click on the 7. Settings button under the Video area. This opens the Standard 

Video Compression Settings dialog box (Figure 2.26). Here you can adjust 

the compression settings. Animation compression works well for Flash movies. 

Leave the frame rate at 30 fps. You will conform it to 29.97 in After Effects. 

Click OK twice to return to the QuickTime Export Settings dialog box.

Figure 2.26: The QuickTime Exporter allows you to control the video compression.

Quit out of all other applications so only Flash is open. Click 8. Export. The 

QuickTime Exporter captures every frame as a SWF movie in the background 

to create the QuickTime movie. This can take a few minutes.

You may need to lower the frame rate to prevent frames dropping. What does 

this mean? If the video size and fast frame rate are too much for the QuickTime 

Exporter, certain frames will be dropped as it renders the movie. 

A dialog box will appear when the QuickTime movie is complete. Click 9. OK.

Open10. scene_02.fla. This animation is set up similar to scene_01. Repeat the 

previous steps to export the file as a QuickTime movie. Once you’ve finished 

creating both QuickTime movies, it is time to import them into After Effects.

Figure 2.25: Turn off the 
audio export. Audio can be 
added later in After Effects.
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Launch11. Adobe After Effects. Import the two QuickTime movies into the Project 

panel. If the Interpret Footage dialog box appears, click on Ignore Alpha (Figure 

2.27). Chapter 4 covers alpha channels in detail.

Figure 2.27: The QuickTime movie does not need an alpha channel. Select Ignore.

Conform the frame rate of both QuickTime footage files to 29.97 fps. 12. To do 

this, select the footage item. Select File > Interpret Footage > Main. In the 

Frame Rate section, select Conform to frame rate and enter 29.97. Click OK.

Deselect any selected footage items in the Project panel. Click on the 13. New

Folder icon at the bottom of the Project panel. Rename it to Comps.

Select14. Composition > New Composition. Enter SnowDay as the Composition 

Name. Select NTSC D1 from the Preset popup menu. Set the duration to 

0:00:10:00. Click OK to create the new composition.

Click and drag both QuickTime footage files to the Timeline (Figure 2.28). With 15.

both layers highlighted select Layer > Transform > Fit to Comp.

Figure 2.28: Add the layers to the Timeline. 

In the Timeline, click and drag 16. scene_02.mov’s colored bar. Align its starting 

point to the end point of scene_01.mov’s colored bar (Figure 2.29).

Figure 2.29: Align the layers to play back one after the other. 

Trim the Timeline’s workspace to the end of 17. scene_02.mov’s colored bar. 

To do this, click and drag the Work Area End handle to align with the end of the 

colored bar (Figure 2.29). The last step is to add some snow to the layer. 

Where this would require either ActionScript or a lot of layers in Flash, After 

Effects has an effect that automatically generates snowflakes. It’s simple.
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Make sure the 18. scene_02.mov layer is selected. Select Effect > Simulation > 

CC Snow. The effect adds falling snow to the animation. You can control the 

amount of snow, its size, and rate of descent in the Effect Controls panel.

Figure 2.30: The CC Snow effect automatically generates falling snow on a layer.

After Effects has the Title Safe and Action Safe guides built into the Comp 19.

Window. To make them visible, click on the Grid & Guides        button at 

the bottom left of the Composition panel. Select Title/Action Safe from the 

popup menu (Figure 2.31). The guidelines appear in the Comp Window.

Figure 2.31: After Effects has the Title Safe and Action Safe guides built in.

Select20. Composition > Make Movie.

Click on 21. Lossless next to Output Module. Set the Format to QuickTime movie. 

Click on Format Options and set the compression setting to MPEG-4 Video.

Click on Output To and select the Chapter_02 folder on your hard drive as 

the final destination for the rendered movie.

Click the 22. Render button. Save your project. As you can see, rendering frame-

based animation using the QuickTime Exporter in Flash is fairly straightforward. 

What’s the benefit of using it over importing a SWF into After Effects? In this 

example, none. In some cases it is better to use the SWF file. So why use it? The 

next exercise clearly demonstrates the benefit of using the QuickTime Exporter.
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Exporting ActionScript-driven Movies
Flash CS3 introduced the ability to export content over a period of time to 

a QuickTime file format. You define the amount of time and the QuickTime 

Exporter records the movement on the Stage whether it is frame-by-frame 

or ActionScript driven. This is a huge improvement and good news for Flash 

programmers who want to export their dynamically driven movies to video.

This final exercise provides a step-by-step tutorial on exporting an ActionScript-

driven animation using the QuickTime Exporter. To see an example, locate and 

play the SpaceWars.mov in the Completed folder inside the 03_ActionScript 

folder (Figure 2.32). When you finish this exercise you will be able to export 

movie clips controlled by ActionScript to a video format.

Figure 2.32: The finished QuickTime movie file uses ActionScript-driven content.

The retro rocketship was created in Flash as a short, frame-by-frame animation 

stored in a movie clip. Through the use of ActionScript, the movie clip is 

duplicated six times and positioned off the left edge of the Stage. Over time, 

each duplicated ship moves across the Stage at a random speed.

Let’s first deconstruct the Flash code. Open the 1. 03_ActionScript folder inside 

the Chapter_02 folder. Here is the breakdown of the files you will look at:

RocketshipCode.fla3  is the Flash document that stores the retro rocketship 
movie clip in its Library.

rocketDocumentClass.as3  is the Document Class that duplicates the ships 
and defines their initial position and speed. 

AnimateShip.as3  is an ActionScript file that positions and moves each ship.
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Double-click on 2. RocketshipCode.fla to open the file in Flash. The Stage is set 

to a customized size of 640 x 320 pixels. There is nothing on the Stage or in 

the Timeline. The Library stores the rocketship movie clip.

Select3. Control > Test Movie to preview the animation. Each time you test the 

movie, you will see six rocketships fly across the Stage at random speeds.

Close the SWF file and return to Flash. Go to the Properties panel. Notice that 4.

the Document class field contains rocketDocumentClass. This is the link to a 

separate ActionScript file that will set up the animation for this Flash document.

Figure 2.33: Link to the Document Class file in the Properties panel.

Select5. File > Open. Choose rocketDocumentClass.as in the 03_ActionScript 

folder. Click Open. The code duplicates the rocketship six times using a for loop. 

Each time through the loop a new movie clip object (AnimateShip) is created. 

For each new object, a random horizontal and vertical position is created based 

on the dimensions of the Stage. It also generates a random speed value. These 

three random numbers are passed as parameters to the AnimateShip.as file.

The last line of code (addChild) draws the movie clip instance on the Stage.

Select6. File > Open. Choose AnimateShip.as in the 03_ActionScript folder. Click 

Open. This code is linked to the movie clip in RocketshipCode.fla through the 

Linkage Properties panel in the Library (Figure 2.34).

Figure 2.34: Link to the ActionScript file in the Linkage Properties panel.

public function rocketDocumentClass() {

   for(var i:uint=0; i < 6; i++) {

    var ship:AnimateShip = new AnimateShip(Math.random()*640 - 700, 

                            Math.random()*200 + 60, Math.random()*10 + 5);

    addChild(ship);

   }

}
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Each time the Document Class creates an object, this AS file is attached to the 7.

new rocketship. Remember, this code is linked to the movie clip. The Action-

Script basically tells the ship where to go and how to move across the Stage 

based on certain parameters sent by the Document Class.

The code first creates a variable called speedX. This will be used to move the 

ship horizontally across the Stage. The Class Constructor is defined and the 

parameters from the Document Class are stored in x, y, and dx. The first two 

parameters are used to position the ship. The rocketship’s scale is set to 40%. 

An Event Listener “listens” for the playback head entering the frame. It calls an 

event handler that moves the ship. Since this file is continuously entering the 

same frame, this function is called repeatedly, creating the movement. The rate 

at which the ship animates is based on the value stored in dx.

Return to the 8. RocketshipCode.fla file. Select File > Export > Export Movie.

This opens the QuickTime Movie dialog box. Select the 03_ActionScript folder 

inside the Chapter_02 folder on your hard drive as the final destination for the 

rendered movie. Make sure the file format is set to QuickTime. Click Save.

The QuickTime Export Settings dialog box appears. Make sure the width 9.

and height are set to 640 and 320 respectively. 

Check the checkbox to 10. Ignore Stage Color. An alpha channel will be 

generated to use in After Effects.

In the Stop Exporting area select 11. After Time Elapsed and enter 00:00:10. Flash 

will record activity on the Stage for 10 seconds (Figure 2.35). This method 

includes movie clips in the captured frames. Click on QuickTime Settings.

public class AnimateShip extends MovieClip {

  // define variable to hold positive speed

  private var speedX:uint;

  // create constructor

  public function AnimateShip(x,y,dx) {

   // set scale, location, and speed

   this.scaleX = this.scaleY = .4;

   this.x = x;

   this.y = y;

   speedX = dx;

   // move the ship to the left each frame

   this.addEventListener(Event.ENTER_FRAME, moveShip);

}

  // move according to speed set in DocumentClass

  public function moveShip(event:Event) {

   // move the ship to the left

   this.x += speedX;

}

}
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Figure 2.35: To export ActionScript-driven content, select After Time Elapsed and 
enter a value. Flash will record any activity on the Stage for the time entered.

Click on the 12. Size button under the Video area. This opens the Export Size 

Settings dialog box (Figure 2.36). Make sure the width and height are set to 

640 and 320 respectively. Click OK twice to return to the QuickTime Export 

Settings dialog box.

Figure 2.36: Make sure the Export Size matches the Stage dimensions.

Quit out of all other applications so only Flash is running. Click 13. Export. A dialog 

box will appear when the QuickTime movie is complete. Click OK.

Go to the 03_ActionScript folder on your hard drive where you will find the 14.

QuickTime movie. Launch the QuickTime movie in the QuickTime player. The 

ability to export ActionScript-driven content is a great improvement for Flash 

and opens the door wider in creating content for After Effects.

Figure 2.37: The QuickTime Exporter recorded the code-driven animation.
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To see how this Flash animation was used to create the Space Wars title 15.

sequence, open SpaceWars.aep in the Completed folder.

The Project panel contains the exported QuickTime movie as a footage item. 16.

Other footage includes two audio files, a sound effect and background music. 

A starfield was created in Photoshop. The title was created in Illustrator as a 

vector shape so that it can be scaled without losing detail (Figure 2.38).

Figure 2.38: The Project panel contains all the footage files used.

Let’s deconstruct how the final composition was created. It was set to the same 17.

duration and frame rate as the RocketshipCode.mov file. All of the footage 

items were added to the composition as layers:

The3 space.tif layer’s height is slightly larger than the composition’s. Two 

Position keyframes animate in a downward movement, like a camera pan.

The3 RocketshipCode.mov layer has no effects or keyframes applied. The 

alpha channel generated by the QuickTime Exporter makes compositing 

easy to do in After Effects. The layer reveals the starfield underneath it.

The3 SpaceWarsTitle.ai layer contains the vector art. The Scale property is 

reduced from 4000% to 100%. An important note worth mentioning is 

the Continuously Rasterize switch that is available for all vector layers in 

the Timeline (Figure 2.39). Activate this switch to maintain the smooth 

detail in the vector artwork as the layer scales larger than its original size.
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Figure 2.39: The Continuously Rasterize button is used on vector layers to maintain 
their smoothness and detail as the layer is scaled larger than its original size.

At the eight second mark (08:00) the title “Space Wars” begins to fade off the 18.

screen using a combination of scale, reducing opacity, and an applied effect. 

The effect used is located at Effect > Generate > CC Light Burst 2.5. It simulates 

rays of light emanating from the layer. To create the “warp speed” effect, two 

keyframes were set for the Ray Length value. The value was increased from 0 

to 500 in the Effect Controls panel (Figure 2.40).

Figure 2.40: The CC Light Burst 2.5 effect was applied to the title layer to 
produce the blurred special effect.

A Solid layer was created to hold a laser beam that shoots out of a rocketship 19.

(Figure 2.41). To create the lasers, the Beam effect was used. This is located at 

Effect > Generate > Beam. This simple effect is used quite frequently to produce 

amateur light saber duels that you see online.

Figure 2.41: The Beam effect was applied to a Solid layer to create the laser beams.

In the Effect Controls panel, the beam’s starting and ending points were set at 

the left edge and right edge of the Solid layer. Keyframes were set for the Time 

property. Its value changes from 0 to 100, creating the movement of the beam. 

This Solid layer was then duplicated six times and repositioned in the Timeline. 

A couple of layers were moved in the Comp Window to align the beam to the 

laser cannon at the end of the rocketship.



62 Chapter 2: From Flash to After Effects

The audio files were added to the Timeline as separate layers. An audio layer 20.

can be positioned anywhere within the stack of layers. A good practice to adopt 

is either position all the audio at the top or the bottom of the layers to keep 

them out of the way while you work.

Figure 2.42: Audio was added last in the Timeline.

The sound effect, Laser.mp3, was duplicated six times and aligned to sync up 

with the animation. The background music spans the entire duration of the 

composition. The last step was rendering the final output.

The composition was rendered as a QuickTime movie and a Flash Video (FLV) 21.

file. Both files were rendered at the same size and frame rate. Notice the file 

size difference between the two formats. The FLV file was linked through the 

FLVPlayback video component in SpaceWars.fla. You can see the final results 

by double-clicking on the published file — SpaceWars.swf.

Summary

This completes the chapter. Some key concepts to remember include:

Frame aspect ratio is the relationship between the width and height of an 3

image. There are two common video aspect ratios — 4:3 and 16:9.

Computers use square pixels and video does not. To compensate for this, 3

adjust the dimensions of your square pixel art to properly display on video.

Frame rate is the speed at which video plays back its frames. NTSC uses a 3

frame rate of 29.97 fps. PAL and SECAM use 25 fps. Film is 24 fps.

Computer screens use a progressive scan while television uses an interlaced 3

scan. The interlaced scan is broken up into two fields of scan lines and can 
affect the display of thin lines and small text.

Title Safe and Action Safe guides solve the problem of television overscan. 3

When publishing a SWF file for After Effects, use graphic symbols and vector 3

shapes. Movie clips within the SWF will not display properly in After Effects.

To export movie clips to After Effects, use the QuickTime Exporter. It will 3

export content on the Flash Stage over a set timespan to a QuickTime movie.


