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Exploring 3D in Flash

We live in a three-dimensional world. Objects and spaces have width, height, and 

depth. Various specialized immersive technologies such as special helmets, gloves,  

and 3D monitors have produced very effective and exciting computer-generated  

virtual reality environments.

 

The first thing you should know about 3D and Flash is that there is no 3D in Flash. That 

is, there are no inherent 3D capabilities built into Flash, either through drawing tools or 

through scripting commands. The kinds of virtual realities mentioned above are just not 

possible with Flash. 

Figure 1.1 Examples of 3D imagery
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What Flash does know how to do, however, is display vector shapes and calculate 

expressions. With that, there is much that we can do if we are willing to look at 3D 

from another viewpoint. In traditional three-dimensional computer graphics, 3D objects 

are normally projected onto the monitor screen used as a picture plane. In many other 

situations we interact in varying degrees with three-dimensional environments project-

ed onto a two-dimensional surface. This is true of photography, film, video, and many 

fine-art paintings. We perceive three-dimensionality through visual and motion cues. If 

we focus on the imagery as pictorial representations of 3D objects and spaces, we open 

up a broad spectrum of potential exploration (Figure 1.1).

 

For example, we can create the illusion of 3D through a variety of drawing techniques. 

The movement of objects themselves can produce a sense of 3D space. We can cre-

ate actual 3D objects, scenes, and animations in software packages outside of Flash 

and then import the results into Flash. Even though layers in Flash are all at the same 

distance to the viewer, we can use them to set up a rudimentary 3D space. We can use 

ActionScript to dynamically create mathematically calculated three-dimensional spaces 

and objects from scratch. And we can use combinations of each of these to create a 

rich panoply of environments.

Flash is based upon 2D objects and positioning. Objects are always the same distance 

from the screen. Movement in this depthless space is either left and right along the 

horizontal or x-axis, or up and down along the vertical or y-axis, or along both axes. 

To create a 3D space, there needs to be a sense of depth towards or away from the 

screen. This involves moving along the z-axis. In Flash, the z-axis doesn’t exist, so we 

need either to find ways to simulate one or to mathematically define one. Exploring 

ways in which this can be achieved is the purpose of this book.

Types of Projections

Before we get into Flash 3D, let’s look at the different ways in which objects can be pro-

jected as 3D drawings. All 3D drawings have four elements in common. They each have

1. a three-dimensional object

2. a picture plane for capturing the object’s projected image

3. projection rays to project the object onto the picture plane’s surface

4. a viewer to observe the object’s image on the picture plane

The 3D drawing varies depending on the relationship between the projector rays and the 

picture plane as shown in Figure 1.2. The projector rays can intersect the picture plane 

in three ways, which produce different types of drawings discussed in the next section.
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Orthographic projections. When all of the projector rays meet the picture plane at right 

angles, the projection is an orthographic projection. Multiview and paraline drawings 

are examples of this type of projection.

Oblique projections. When all of the projector rays are parallel to one another and at 

an oblique angle to the picture plane, the projection is an oblique projection. General 

oblique and transoblique drawings are examples of this type of projection.

Perspective projections. When all of the projector rays form various angles to the 

picture plane and converge to a single point, the projection is a perspective projection. 

One-point, two-point, and three-point perspective drawings are examples of this type  

of projection.

Types of 3D Drawings

It will be helpful to briefly discuss some of the more common types of 3D drawings 

used by designers, artists, and architects. In some cases, the drawings are roughly 

sketched out by designers without the use of a formal projection system. In others, 

they might be carefully constructed or generated with 3D software.
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Figure 1.2 Types of projections
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Multiview Drawings

Multiview drawings may consist of elevation, plan, and sectional views. These views 

are commonly used in 3D programs. Three-dimensional objects are often constructed 

by creating the top (plan), front, and side (elevation) views of the object. Simple 3D 

objects such as extrusions and lathed objects use cross-sections of the shape.

Multiview drawings are often called orthographic projections since they are typi-

cally rendered at right angles from one another. Figure 1.3 shows a typical multiview 

arrangement of a simple 3D object. Although none of the multiview drawings separately 

can truly represent the actual configuration of a three-dimensional object, there are 

many times when just a front view or side view adequately conveys the sense of 3D 

objects or space. 

Single-View Drawings

Single-view drawings present more than one side of an object in the same view. There 

are two types of single-view drawings: paraline and perspective. In paraline drawings, 

any two parallel lines or planes remain infinitely parallel, while in perspective draw-

ings, parallel lines appear to converge at one or more vanishing points. When drawing 

or sketching by hand for generating 3D ideas or for scanning, paralines are faster and 

easier to construct than perspectives.

Figure 1.3 Typical multiview arrangement

Left Side Front Right Side Back
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Paraline Drawings

Figure 1.4 shows an example of two of the most frequently used paraline drawings, 

both of which can easily be constructed. With isometric drawings, the three primary 

axes of measurement include two ground-plane axes drawn at 30º angles from a 

horizontal and a vertical height axis parallel to the picture plane. All measurements 

are made along (or parallel to) these three axes at exact scale, which makes isometric 

drawings the easiest to construct. 

Exact shapes in each dimension are characteristic of isometric drawings. While they  

are easy to construct, isometric drawings have a few drawbacks. A main one is that  

the three visible faces are always turned at the same angle to the picture plane.  

Another drawback is that isometric drawings tend to look somewhat unnatural due  

to a lack of foreshortening.

Like isometric drawings, dimetric drawings have one axis parallel to the picture plane. 

Dimetric drawings can be either symmetric or nonsymmetric as shown above. They are 

characterized by having two of the three axes drawn at the same scale. Convenient 

scale ratios such as 1:3/4 or 1:2/3 are normally used. Dimetric drawings tend to look a 

little more realistic than isometric drawings because of foreshortening. In addition, the 

nonsymmetric versions provide the advantage of enabling you to place more emphasis 

on important views while downplaying less exciting ones.

Another class of paraline drawings is oblique drawings as shown in Figure 1.5. True 

size and shape are retained in plan oblique drawings. The plan is usually tilted at an 

angle, and the height lines are drawn as verticals. Different variations can be obtained 

by changing the angle of the plan and altering the scale ratio between the plan and the 

receding height lines.

Isometric   Symmetric Dimetric Non-symmetric Dimetric

Figure 1.4 Isometric and dimetric drawings
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Elevation oblique drawings are characterized by having one set of planes presented in 

true size and shape. All planes parallel to the picture plane are drawn in true shape and 

at the same scale. Planes perpendicular to the picture plane are drawn at a reduced 

scale. Convenient scale ratios such as 1:3/4 or 1:2/3 are often used. As with plan 

obliques, the angle of the perpendicular planes can be altered to meet individual needs.

Transoblique drawings are a special case of paraline drawings that show only two or-

thogonal surfaces in a single view, unlike the other drawings we have seen that depict 

three surfaces in the same view. Elevation planes parallel to the picture plane are typi-

cally drawn at true size and shape. Perpendicular planes are drawn at some convenient 

scale such as 3/4 or 2/3. The result is a drawing that is somewhat more than 2D but 

somewhat less than 3D.

Paraline Drawings in Flash

Flash provides the tools to create paraline drawings of simple shapes based on multiview 

orthographic drawings. The following short exercises will acquaint you with the basic 

steps of scaling, rotating, and transforming shapes to generate paraline drawings. 

Exercise 1.1: Creating an Isometric Drawing

Step 1: Getting started

Open the file 1_1_desk.fla in the Chapter 1 folder on the accompanying CD. The 

artwork for this exercise consists of four of the six orthographic projections of the desk 

from Figure 1.3. The text and each view are on separate layers in the movie Timeline 

(Figure 1.6). It will be helpful to zoom in to 200% and hide the text layer.

Plan Oblique    Elevation Oblique             Transoblique                       

Figure 1.5 Plan oblique, elevation oblique, and transoblique drawings
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Step 2: Create the right side isometric

Use the arrow selection tool to select the right side view. If the Transform palette is not 

visible, choose Window > Transform to open it. Select the Skew option and enter a ver-

tical skew value of –30 degrees (Figure 1.7). Flash will skew the right side the correct 

amount while maintaining the required size relationships.

Figure 1.6 Front, top, and side views of a desk

Figure 1.7 The right side isometric with a negative vertical skew
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Step 3: Create the front isometric

For convenience, hide the top view layer. Select the front view. Choose the Skew option 

in the Transform palette and enter a vertical skew value of 30 degrees. Move the front 

view into position with the side view as shown in Figure 1.8.

Step 4: Create the left side isometric

Next select the left side view. Choose the Skew option in the Transform palette and  

enter a vertical skew value of –30 degrees as with the right side. Move the left side 

view into position with the front view to establish the thickness of the table leg as 

shown in Figure 1.9.

Figure 1.8 The front isometric with a positive vertical skew

Figure 1.9 The left side isometric with a negative vertical skew
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Step 5: Create the top isometric

Turn the top view back on so that it can be seen. Unlike the other views, the top view 

must be skewed both horizontally and vertically. The question is, how much of each do 

we need? It’s not really obvious, but with a little bit of thought we can work it out. 

We have seen from the previous views that we can transform horizontal lines up to the 

left and right by entering vertical skew values of +30 and –30 degrees respectively. For 

the top view, we will need to use a vertical skew value of 30 degrees to match up with 

the front view.

To transform the vertical lines of the top view, we need to do the opposite and skew 

horizontally. The 90-degree vertical lines of the top view must be parallel to the hori-

zontal lines of the side views, which are now at a 30-degree angle. The vertical lines of 

the top view must then transform a net amount of 60 degrees to match up. How do we 

know if it is +60 or –60 degrees? The small diagrams in the Transform palette indicate 

the direction of positive skew angles. In Flash, positive values of angles are measured 

clockwise. 

We now have the information we need to skew correctly. Use the arrow selection tool 

to select the top view. In the Transform palette, select the Skew option and enter 60 

degrees for the horizontal skew and 30 degrees for the vertical skew. Move the top  

isometric into position with the rest of the drawing as shown in Figure 1.10, and you 

are done with the exercise. Save your file as desk_Isometric.fla.

Figure 1.10 The top isometric with horizontal and vertical skews
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Exercise 1.2: Creating a Symmetric Dimetric Drawing

Step 1: Getting started

Open the file 1_1_desk.fla in the Chapter 1 folder on the accompanying CD. As in the 

previous exercise, it will be helpful to zoom in to 200% and hide the text layer.

Step 2: Set the horizontal scale factor

Referring to Figure 1.4, we see that for symmetric dimetric drawings, we need to 

change the horizontal scale of each view to 75%. Choose Edit > Select All. In the 

Transform palette, set the width (horizontal scale) to 75% (Figure 1.11).

Step 3: Skew the front and side views

As with the isometric drawing, we will need to vertically skew the sides and front views.

1.	 Select the right side view and set the vertical skew to –15 degrees.

2.	 Select the front view and set the vertical skew to 15 degrees.

3.	 Select the left side view and set the vertical skew to –15 degrees.

4.	 Move the sides into position as shown in the left side of Figure 1.12.

Step 4: Complete the left side view

We need to add some thickness to the rear leg of the desk. We can do this easily by 

Figure 1.11 Use the transform palette to set the width of all objects to 75%.
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making a copy of the front, pasting it in, and moving it into position. Since the copy is 

on top of the original front view, choose Modify > Arrange > Send to Back. Your draw-

ing should now look like the right side of Figure 1.12.

Step 5: Complete the drawing

We just need to transform the top view to complete the drawing. Select the top view. 

We have previously set the width to 75% in the Transform palette, and we must now 

also set the height to 75% so that its height matches the width of the sides.

To determine the skew angles, we will apply the same reasoning as in the previous 

exercise. The horizontal sides of the top must be vertically skewed 15 degrees to match 

the horizontals of the front side. The vertical sides of the top must be horizontally 

skewed 75 degrees to align with the –15 degree skew of the right and left sides. Enter 

these values in the Transform palette, then move the top into position, and you should 

have the results of Figure 1.13. Foreshortening the drawing by changing the width 

makes the desk appear more realistic than in the isometric drawing. Save your file as 

desk_Dimetric1.fla.

Figure 1.12 Front and sides of the symmetric dimetric desk drawing

Figure 1.13 The completed symmetric dimetric desk drawing
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Exercise 1.3: Creating a Nonsymmetric Dimetric Drawing

Referring to Figure 1.4, we see that for nonsymmetric dimetric drawings, we have a 

little more flexibility to emphasize one side more than another because of the two dif-

ferent horizontal scale factors and the vertical skew angles. So for a change of pace, 

in this drawing we will place primary emphasis on the front of the desk and secondary 

emphasis on the left side. 

Step 1: Getting started

Open the file 1_1_desk.fla in the Chapter 1 folder. As in the previous exercise, it will 

be helpful to zoom in to 200% and hide the text layer.

Step 2: Skew the front view

Select the front view. Because it is the primary view, we do not need to change any 

scale factors. In the Transform palette, set the vertical skew angle to –15 degrees.

Step 3: Size and skew the left side

Select the left side view. In the Transform palette, set the width to 75% and the vertical 

skew angle to 30 degrees. Move the left side into position with the front (Figure 1.14).

Step 4: Add the right side thickness

Select the right side view. We will use it to define the depth of the desk drawers. In 

the Transform palette, set the width to 75% and the vertical skew angle to 30 degrees. 

Move the right side into position with the front as shown in Figure 1.15.

Figure 1.14 Size and skew the left side of the dimetric drawing
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Step 5: Add the left leg thickness

The left rear leg of the desk is only partially defined. If we had a back view available, 

we could use it to give the leg thickness. Since we don’t, let’s try what we have done 

before by copying and pasting the front view and then moving the copy into position 

to define the leg. As before, choose Modify > Arrange > Send to Back to get the front 

copy behind the original. 

Unlike earlier, we still have a problem. The duplicated front needs to be behind every-

thing. We can easily solve this by adding a new “back” layer between the text layer and 

the left layer and pasting the copy into the new layer as shown in Figure 1.16.

Figure 1.15 Size and skew the right side of the dimetric drawing.

Figure 1.16 Place the front copy on a separate layer below the others.
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Step 6: Complete the drawing

We just need to transform the top view to complete the drawing. Select the top view. 

To match the vertical sections of the top with the horizontal width of the sides, we have 

set the top view’s height to 75% in the Transform palette. 

To determine the skew angles, we will apply the same reasoning as in the previous ex-

ercises. The horizontal sides of the top must be vertically skewed –15 degrees to match 

the horizontals of the front side. The vertical sides of the top must be horizontally 

skewed –60 degrees to align with the 30 degree skew of the right and left sides. Enter 

these values in the Transform palette, then move the top into position, and you should 

have the results of Figure 1.17. As with the previous exercise, foreshortening the left 

and right sides by changing the width makes the desk appear more realistic than in the 

isometric drawing. Save your file as desk_Dimetric2.fla.

Tip: Use 1_1_desk.fla, Figure 1.5, and what you have learned in the last three exer-

cises to develop plan oblique, elevation oblique, and transoblique drawings of the desk 

as shown in Figure 1.18.

Figure 1.17 The completed nonsymmetric dimetric desk drawing

Figure 1.18 Plan oblique, elevation oblique, and transoblique desk drawings
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Types of Perspective Drawings

Perspective drawings are the most realistic type of representational drawing. If all pro-

jection rays of an object converge on a common vanishing point, their intersection with 

the picture plane produces a perspective image of that object. This is the most realistic 

of the 3D drawings. Three types of perspective drawings can occur. 

One-point Perspective

If one face of an object is parallel to the picture plane or if horizontal lines and vertical 

lines are parallel to the picture plane, the resulting image is a one-point perspective 

(Figure 1.19).

Two-point Perspective

If only vertical lines are parallel to the picture plane and no faces of the object are par-

allel to the picture plane, the resulting image is a two-point perspective (Figure 1.20).

Horizon Line VP

Horizontal and vertical lines 
are parallel to the picture plane

Figure 1.19 One-point perspective drawing has one vanishing point.

Only vertical lines are
parallel to the picture plane

VP VPHorizon Line

Figure 1.20 Two-point perspective drawing has two vanishing points.
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Three-point Perspective

If no faces or edges of an object are parallel to the picture plane, the resulting image is 

a three-point perspective (Figure 1.21).

While it is possible to create perspective drawings in Flash or Illustrator, constructing 

them in a 3D program such as Swift 3D and importing them into Flash is often faster 

and easier and provides greater flexibility.

Summary

This chapter focused on creating the illusion of 3D through a variety of drawing tech-

niques. Key concepts to remember include the following:

• �All 3D drawings have four elements in common: a three-dimensional 

object, a picture plane, projection rays, and a viewer to observe the 

object’s image on the picture plane.

• Types of 3D drawings include multiview, single-view, and paraline.

• �Perspective drawings are the most realistic type of representational 

drawing.

The next chapter focuses on visual depth cues and how to reproduce them in Flash.

All lines are oblique
to the picture plane

VP

VP VPHorizon Line

Figure 1.21 Three-point perspective drawing has three vanishing points.


